Which Android and iOS versions should I support?

Which Android and iOS versions should I support?

When developing a new mobile app it’s always good to take advantage of new technologies. Each new versions of Operating Systems give developers ability to do amazing things within our apps, but finding the balance between implementing new features while supporting existing user base is crucial.

 

Even the best solutions won’t bring good results if that means cutting out significant part of your audience. We’ve already described some things that are important when developing mobile app. Now let’s have a look at what you should keep in mind when it comes to decide which OS versions should you support.

Adoption rate

One of the most important things to consider is how fast users upgrade their OS to new version.

When it comes to iOS the adoption rate is really high. It’s because Apple controls both operating system and the hardware.

app_store_ios_versions

95% of Apple devices are running on iOS 8 or 9

As a result upgrading to newer version of iOS is limited only by the age (capabilities) of device and the willingness of users.

Right now almost 80% of Apple devices are running on iOS 9 and only 5% on previous version than iOS 8.

To be able to reach over 90 % of users you need to support 4 OS versions

To be able to reach over 90 % of users you need to support 4 different OS versions

On the other hand number and variety of devices running on Android is very big so adoption rate is much lower when compared to iOS. Newest version (Marshmallow) is still on only 2% of devices. 90% runs either on Jelly Bean (ver. 4.1-4.3), KitKat (ver. 4.4) or Lollipop (ver. 5.0-5.1).

App Complexity

Another factor that might help decide which versions to support is complexity of your app. When following KISS principle (Keep It Simple Stupid) and not planning to use cutting edge technology because your product is fine without it, then you can easily choose to support older versions of OS as well. Some apps are perfect for being simple and sometimes doesn’t even require network connection.

Select your features

Luckily it is also possible to add capabilities that require newest OS versions and devices while keeping  your app running on older ones simply by filtering those capabilities out.

Development tools such as Xcode for iOS and Android SDK make it easier to do so thanks to automating all the little tasks you would have to perform in order to support various versions and devices.

Conclusion

The answer to question which iOS version to support is relatively easy: iOS 9 and 8 will be enough. From our experience you can’t go wrong with simply supporting iOS version from prior year.

When it comes to Android it will be wise to support three main ones: Jelly Bean, KitKat, Lollipop and the newest: Marshmallow.

Leave a comment